самодельный станок с ЧПУ, отзывы duxe.ru

Информация о пользователе

Привет, Гость! Войдите или зарегистрируйтесь.



Нужно ли настраивать LPT-порт?

Сообщений 1 страница 22 из 22

1

Нужно ли настраивать LPT-порт или драйвера какие устанавливать?Собрал три платы-ниодна не работает.Мотор только дрожит наверно только половина обмоток работает.Две платы тм7+L298, тм7 использовал 155 и одна тм7+MP4101 использовал 155+MP4020(может этот драйвер неподходящий)

0

2

РоманН написал(а):

Нужно ли настраивать LPT-порт или драйвера какие устанавливать?

У меня win2000 ничего не устанавливал, ничего не настраивал
просто скопировал программу Романа и все заработало :hobo:

0

3

РоманН написал(а):

Мотор только дрожит наверно только половина обмоток работает.

Если мотор дрожит значит импульсы на него поступают ,проверьте правильность подключения обмоток .А еще лучше "побитно" с помощью программы на вкладке "Настройка" .Методика описана в соответствующем разделе форума .
У меня также все заработало сразу и без дополнительных настроек .ОС WinXP SP1 ,в BIOS'е режим порта установлен как SPP (standard parallel port) .

0

4

обмотки поразному пробовал...
подключал по одной-одна сильнее держит другая слабже почему то
тм проверял прогой Романа-работает
как прверить MP4020?в принцыпе должна быть рабочей так как выпаял из исправного принтера и блок питания оттудаже
кстате на схеме указано двухполярное питание а я использую обычное-имеет это значение?

Отредактировано РоманН (2008-10-03 13:13:48)

0

5

вот схема

увеличить

0

6

РоманН написал(а):

кстате на схеме указано двухполярное питание а я использую обычное-имеет это значение?

В случаях когда указывают двухполярное питание на схеме это имеет значение и немаловажное :yep:

На вашей схеме на стабилизатор 7805 идет однополярное питание от+8 до +15 Вольт
т.есть минус на корпус , плюс на стабилизатор

(обычно минус по питанию на такой схеме не ставят, он наверное вас смутил)
а если питание двухполярное то есть 3 отдельных вывода
1-минус 2-плюс 3- корпус

да и мне еще ни разу не попадались цифровые микросхемы с двухполярным питанием,
обычно двухполярное питание идет на аналоговые микросхемы ,например операционные усилители,

А второе питание Uдв - это питание непосредственно двигателей,
оно бывает разным в зависимости от типа двигателя
поэтому на схеме нет скока туда вольт надо подать :hobo:

Отредактировано Smenton (2008-10-03 18:03:00)

0

7

РоманН написал(а):

кстате на схеме указано двухполярное питание а я использую обычное-имеет это значение?

Это не двуполярное питание.
Вы можете использовать на логику и разные двигатели разные источники питания, а можете один, соединив все плюсы в кучу(если источник удовлетворяет вас по напряжению и мощности)

0

8

РоманН написал(а):

как прверить MP4020?в принцыпе должна быть рабочей так как выпаял из исправного принтера и блок питания оттудаже

Какое напряжение подаете на обмотки двигателя и какой шаговый двигатель?
Проверить можно подключив к контроллеру вместо двигателя обычные приборные автомобильные лампочки (маленькие, со щитка приборов)

0

9

Спасибо, мотор закрутился (поменял тм) но нагревается сильно и момент на валу слабый-при небольшом усилии пальцами держу

0

10

РоманН написал(а):

но нагревается сильно и момент на валу слабый

Я же не зря спрашиваю про тип двигателя и напряжение, не хотите отвечать - мучайтесь сами :)

0

11

извиняюсь пропустил
напряжение подаю 24в
блок питания из тогоже принтера что и мотор
на моторе написано 24в

пробовал 12в-еле крутится

Отредактировано РоманН (2008-10-05 10:58:47)

0

12

И что сегодня за день? Еще раз спрошу - какой тип двигателя?  То что на нем написано 24 вольта - ничего не значит, то что он еле крутит при этом напряжении - мне тоже ни о чем не говорит. Скажи хоть из какого принтера и откуда(с подачи каретки или вращения бумагопорного вала) снял его? Да, еще: Измерь напряжение на включенной обмотке.

0

13

двигатель униполяр-5 проводов,принтер не помню а двигатель стоял на подаче бумаги, напряжение на обмотке 10в,подаю 12в-на обмотке 3.8в
может всётаки драйвер неподходящий?

Отредактировано РоманН (2008-10-05 17:33:46)

0

14

РоманН написал(а):

может всётаки драйвер неподходящий?

А может ты его неправильно подключил?
Померяй между корпусом и выходом драйвера, должно быть примерно  1 вольт. Если больше - померяй между корпусом и входом драйвера, должно быть более 2,5 В.
Если на входе драйвера напряжение ниже 2,5 В - меняй ТМ7.
Если на входе драйвера больше 2,5 вольта, и на выходе драйвера больше 1,6 вольта - проверь еще раз монтаж и только если все в порядке - меняй драйвер.

0

15

померял
между корпусом и выходом драйвера-3нога 0.57
                                                         5нога 0.57
                                                         7нога 0.57
                                                         9нога 0.45
между корпусом и входом драйвера 2нога 1.27
                                                       4нога 1.27
                                                       6нога 1.27
                                                       8нога 1.12
и ещё-с LPT приходит не 5в, а 4.08в (может тестер врёт?..)

0

16

У тебя открыты все драйверы, потому все и греется.
На шаговый двигатель подается напряжение только на одну обмотку, а не на все сразу,
когда напряжение переключается с одной на другую, а потом на третью и на четвертую обмотки двигатель каждый раз делает шаг.
Или ты неправильно устанавливаешь напряжение на выходе порта или сгорела ТМ7.
И еще куда то девалась часть напряжения источника питания. Если ты подаешь 12 вольт, а на ключах 0,7, то на обмотке должно быть остальные 11,3 В. Посмотри чего напутал.

+1

17

эт я с отключенным LPT мерял, щас подключил запустил Hardware Control пошагово меряю:

1шаг-9нога 23.5в
2шаг-7нога 23.4в
3шаг-5нога 23.4в
4шаг-3нога 23.4в

+тестера контачил с +питания (может это неправильно?)

значит срабатывает всё нормально?...

Отредактировано РоманН (2008-10-07 09:51:59)

0

18

Меряешь ненормально.  :)  Выстави на хардвере все нули, кроме одного, и измеряй напряжение по этому каналу последовательно от порта до источника питания.

Вот тебе контрольные точки и примерный диапазон напряжений на них для случая когда в хардвере по этому каналу установлена 1,( а в скобках - если установлен 0 ).

Выход порта - 2-5 (0-0,5)
Выход ТМ7 -  1,5 - 5 (0-0,5)
Вход драйвера - 1 - 4(0-0,5)
выход драйвера - 0,5 -4 ( напряжение, близкое к напряжению источника)
Источник питания - ?

Только не забывай, что после установки напряжение в порту, надо установить  и сбросить 1 на выходах 6,7 или 8)

0

19

результат:

Выход порта - 3.92
Выход ТМ7 -  3.43
Вход драйвера - 1.27
выход драйвера - 0.57
Источник питания - 24в

Отредактировано РоманН (2008-10-07 10:58:18)

0

20

фотки мотора

увеличить

увеличить

увеличить

0

21

РоманН написал(а):

результат:

Нормальное состояние, если так же другие каналы работают, то можно считать что контроллер в порядке.
то для этого движка напряжение придется подобрать по его нагреву. Максимальная температура после прогрева - 70-80 градусов,
тогда и момент на валу будет максимальный. Большего не добьешся.

0

22

Большое спасибо за ответы
Подскажите ещё пожалста как снизить напряж на блоке питания -на нём написано:24(27.6)V_ _ _0.55(0.45)A
Может это он 27в даёт-поэтому мотор и греется сильно?
А если 3 мотора подключу может нормально будет?

0